IMPORT STUDENTS

This option allows you to electronically update your student data using a data file created from the districts main student file. You can import student information from your district's main computer system as often as you like. Every day, every week or once a year. If you prefer to import once a year, please make sure you import into the appropriate scenario. If the district files has graduated students, then you need to import into the graduated scenario.

Import Students Screen

Importing will automatically do the following:

  • Add students using the entrance date designated in the import file
  • Make students inactive that have withdrawn from the district and are still active in BusBoss™
  • Update student information (address changes, school transfers, etc.)

NOTE: When data is imported it will be imported into the current scenario.

Import File Format

The import file you use must be in a specific file format (ASCII comma delimited, ASCII tab delimited, or ASCII quote comma delimited) with the following field specifications:

Field Number Max Field Length Field Description
1 1 Active/Inactive (A or I)
2 9 Student ID Number
3 25 Student Name (Last name first)
4 5 *House Number
5 2 *Prefix
6 25 *Home Address Line 1
7 5 *Street Type
8 4 *Suffix
9 40 Address 2
10 20 City
11 2 State
12 10 Zip Code
13 41 Mailing Address (Max. for each * applies)
14 40 Mailing Address 2
15 20 Mailing City
16 2 Mailing State
17 10 Mailing Zip Code
18 25 Guardian 1 Name
19 25 Guardian 2 Name
20 18 Guardian 1 Home Phone
21 18 Guardian 2 Home Phone
22 18 Guardian 1 Work Phone
23 18 Guardian 2 Work Phone
24 10 Date of Birth (mm/dd/yyyy)
25 2 Race
26 1 Sex
27 2 Grade
28 4 Current School Code
29 4 Previous School Code
30 10 Entrance Date (mm/dd/yyyy)
31 10 Exit Date (mm/dd/yyyy)
32 No limit Special Medical Condition
33 No limit Comment
34 5 Home Room
35 20 Info1
36 20 Info2
37 20 Info3
38 20 Info4
39 18 Guardian 1 Cell Phone number
40 18 Guardian 2 Cell Phone number
41 18 Guardian 1 Pager number
42 18 Guardian 2 Pager number
43 50 Guardian 1 E-Mail
44 50 Guardian 2 E-Mail
45 10 School District Code  
46 10 School County Code  
47 50 State Id  
48 50 Student District Code  
49 No limit Guardian 1 Language  
50 No limit Guardian 2 Language
51 No limit Guardian 1 Relationship
52 No limit Guardian 2 Relationship

 

All of these fields must be in the specified order. Even if some of the above information is not available, the rest of it will import as long as the order is consistent. While preparing to import, information can be shifted to the right to fill in columns with missing information. Beware, any information contained in the last column will be lost if columns are shifted to the right.

NOTE: Student ID numbers in the import file must match the student ID numbers in BusBoss™ (including the same number of leading zeros) exactly in order to update student data accurately.

IMPORT STUDENTS FILE MENU

Import Students File Menu

The File menu contains the following functions:

Open Data File (Also found in the shortcut toolbar)

To select the import file to use, click File then Select Open Data File. Browse for the location of the file. When the file is found, select the file and click Open and the path and filename will be displayed in the Import File field. This file will be set as your default file until another file has been selected.

Import Students Data Screen

Prior to loading the student information a window will pop up questioning header row information.

Import Students Header Row Verification

Click Yes if the 1st row has the column headings, click No if the 1st row has student information.

Before importing student data, you need to look at the contents of the import file to make sure the data is accurate. All of the data contained in the import file will be displayed in the table.

Import Students Data Screen

The information can now be manually changed if needed, or imported as is. It is recommended to use the tools provided for making changes in bulk.

Save Data

After correcting errors and making changes to the import file you can save the corrected version of the file. Click File, then Save Data. If overwriting the loaded file, Click Save. If saving to a new file, select where you want to save the file and name it. Click Save and the file will be saved with your changes.

NOTE: It is a good idea to save the corrected file in case you need to rerun the import process. However, it is recommended that you do not overwrite the original import file with the corrected version of the file. Select another name for this file.

Configuration

The configuration options window contains options that are available to automate the import student process. These options cannot be undone without changing these settings and reloading the data file. The original data file will not be affected.

Import Students Configuration Screen

Most choices in this menu are either Yes or No. Any differences are described with the pertaining menu option. The options available on this menu are:

  • Load Last File - Automatically open and load the last data file that was used.
  • Header Row - If there is a header row in the import file, it should not be imported into BusBoss™. Select to always omit the first row, never omit the first row, or prompt before action.
  • Trim Student IDs - Automatically removes leading zeros from import file data.
  • Pad Student IDs - Automatically adds leading zeros to student IDs being imported to BusBoss. Select the number of zeros to add in front of the Student IDs.
  • Format Birthdates - Formats birthdates into MM/DD/YY or MM/DD/YYYY format.
  • Format Phone Numbers - Formats phone numbers into 555-555-5555 format.
  • Hide Matching Data - Automatically hides matching data between the import file and BusBoss™
  • Remove Students - Automatically removes students from the import file if all data for that student exists in BusBoss™
  • Show New Students - Will automatically compare students in the import file to students in BusBoss™. New students will be highlighted in the Import Students Screen
  • Ignore Name Changes - Will ignore changes to the student's name during import. The name in BusBoss™ will be replaced with the name in the import file.
  • Ignore Grade Changes - Will ignore changes to the student's grade during import. The grade in BusBoss™ will be replaced with the grade in the import file.
  • Compare Data - Will automatically compare student data between the import file and BusBoss™.
  • Validate Data - Will automatically validate all data in the import file.
  • Import Non-Critical Data - Will automatically import any data that does not affect routing.
  • Import Students - Will automatically validate all data. If there are no errors, the data will automatically be imported.
  • Auto-Locate Addresses - Will auto-locate addresses after import.
  • Determine Rider Eligibility - Will automatically determine rider eligibility for students after addresses are located.
  • Assign Bus Stops - Will automatically assign bus stops to all students that are riders.
  • Assign Students To Routes - Will automatically assign students to routes after assigning bus stops. Select to always perform this action, never perform this action, or to prompt the user before performing this action.

Hide Matching Data

This function will compare data in the import file to data currently in BusBoss™. If any data matches between the import file and BusBoss™, it will be hidden during the import. Only matching information will be hidden. Any new data will be imported

Remove Students

This function will compare data in the import file to data currently in BusBoss™. If all data for a student already exists in BusBoss™, it will be removed from the import.

Compare Data (Also found in the shortcut toolbar)

This will use the student id number to match to a student id number in BusBoss™ and compare the student's information in the import file to the student's information stored in BusBoss™. If they are different in any way, a screen will pop-up displaying the differences in red. The student's Name, School, Grade and Address are used to make the comparisons.

Check Addresses Comparison Screen

If the student has moved and the address is totally different, select the Skip option to continue to the next student.

If the addresses are slightly different, such as street type or zip code, you have the options to Update the Import File to match the BusBoss™ data or Update BusBoss™ to match the Import File.

Update Import file will make changes to the address information to match what is in BusBoss™. You will have the opportunity to Export these Address changes to an ASCII file after Check Addresses is complete. This ASCII file is available for electronically updating the Student Accounting program to match the addresses stored in BusBoss™. It can also be printed and used to manually change them.

The information displayed on the left side is from the Import File. The information displayed on the right side is from BusBoss™.

Name

If the name is different in any way, then the names on both sides will be displayed in Red.

School

If the school code assigned to the student is different, then the school codes on both sides will be displayed in Red.

NOTE: Any imported school code changes to a student that has stops and/or routes assigned to it in BusBoss™ may result in unassigning their current stops and/or routes.

Grade

If the grade assigned to the student is different, then the grades on both sides will be displayed in Red.

Address

If the student has moved and the address is different in anyway, then the addresses on both sides will be displayed in Red.

NOTE: Any imported address changes to a student's home address that has stops and/or routes assigned to it in BusBoss™ will result in unassigning their current stops and/or routes.

Use Import File

Select one for each of the items listed (Name, School, Grade and Address). Making this selection will make changes in BusBoss™ to match what is in the Import file. Address changes will not delete the prior address, it will assign the new address as their Home Address and rename the prior address to Home1. This will retain any historical routing assigned to the old address.

Use BusBoss™

Select one for each of the items listed (Name, School, Grade and Address). Making this selection will make changes to the Import File to match what is in BusBoss™. You will have the opportunity to Save Changes made to the import file after Compare Data is complete. This text file is available for electronically updating the Student Accounting program to match the information stored in BusBoss™. It can also be printed and used to manually change them.

Click Next to proceed to the next student. Click Finish when all of the students have been compared. If you have selected to Use BusBoss™ for any of the differences, then the following screen will pop up.

Save Changes Option Screen

Click Save Changes to create a text file or Discard Changes to continue without saving the changes.

NOTE: The changes to the import file will still be made, you just won't have a record of what those changes were.

Enter the name and directory to save the file and click Save.

Show New Students

To highlight all of the new students in the file, Click File, then Show New Students. The screen will now highlight the row with any student id number that does not exist in BusBoss™.

Validate All Columns (Also found in the shortcut toolbar)

To check if the data in all the columns at once for any inconsistencies, Click File, then Validate All Columns. Across the bottom, a report will display on the screen with the results of the validation. If errors are found, you should change the data before importing it.

Import Students Validate All Columns Screen

Errors

Click on the Errors box and the rows with errors will be listed to the right. Click on one of the errors and BusBoss™ will automatically take you to the field with the invalid data. Correct the information as needed and continue onto the next error. The Errors list will not be updated until you click to Validate All Columns again. Errors are anything relating to students address and school codes. Any invalid data found here may affect students routing information.

Warnings

Click on the Warnings box and the rows with warnings will be listed to the right. Click on one of the warnings and BusBoss™ will automatically take you to the field with the invalid data. Correct the information as needed and continue onto the next warning. The Warnings list will not be updated until you click to Validate All Columns again.

NOTE: Every column should be validated prior to importing to make sure there are no errors in the data. If you import student data into BusBoss™ that still has errors, you may corrupt your database. Invalid data will not be imported.

Import Student Data (Also found in the shortcut toolbar)

Click File, then Import Student Data to begin importing students. A message will tell you that this process may take a long time depending on the number of records you are importing. It also reminds you to make sure the information in the import file is accurate before importing.

Import Students Confirmation Screen

Click OK to import the file or Cancel to cancel.

NOTE: After importing students, it is recommended that you run the following: 1) BusBuster™ (Student), 2) Exact Locate Addresses (All), 3) Auto assign walkers 4) Auto Assign Students to Stops

IMPORT STUDENTS COLUMN MENU

Import Students Column Menu

If you need to make changes to your import file data, there are several ways you can do this. To change the data in an individual cell of the table, double click on that cell. Modify the data in the cell as needed.

Insert

To move a column of text one column to the right, first highlight the column by clicking on the column heading. Click Columns, then Insert. This will push the data in the highlighted column over to the right. Use this if your data is not in the correct column. Beware that any data in the last column will be lost if you insert a column.

Delete

To move a column of text one column to the left, first highlight the column by clicking on the column heading. Click Columns, then Delete. This will move the data in the highlighted column back to the left. Use this if your data is not in the correct column. Beware any data in the columns being deleted will be lost.

Find (Also found in the shortcut toolbar)

To search for a specific student, student id number, phone number, etc. click Columns, then Find.

Find Next

To search again for the same specific student, student id number, phone number, etc. click Columns, then Find Next.

Replace

To replace text in a column, first highlight the column by clicking on the column heading. Click Columns, then Replace. Enter the search text and the text to replace it with. Click OK and the replacements will be made.

Sort (Also found in the shortcut toolbar)

You can sort the data displayed in the table in ascending order by any column of information. For example, if you want to sort the data by student name, first highlight the student name column by clicking on the column heading. Click Columns, then Sort. The entire table will be sorted in alphabetical order by student name. Sorting columns makes it easier to group information for Copying, Pasting, and Cutting data as needed.

NOTE: You can use the following keyboard shortcuts [Ctrl][C] = Copy, [Ctrl][V] = Paste, [Ctrl][X] = Cut

IMPORT STUDENTS RECORDS MENU

Import Student Records Menu

Insert

If you want to insert a student record to the import file. Click Records, then Insert. A blank row will be inserted into the table and the student manually entered into this row will be imported. Be sure to enter the student information in the proper columns prior to importing.

Delete

If you want to delete a student record from the import file, first highlight the row you want to delete. Click Records, then Delete. The row will be deleted from the table and that student will not be imported. If the import file has a record for the header row, use this to delete it prior to importing.

Filter (Also found in the shortcut toolbar)

Filtering will allow the user to import only the students matching the selected criteria. Click Records, then Filter. The following screen will pop up.

Import Students Filter Screen

Select the desired filtering and Click OK to automatically select the students matching the selected filtering. Users can also select and unselect each student by clicking the Include column prior to the student's Active/Inactive status. The available filters are:

Active/Inactive

  • Active Only - Students with an A in the Active/Inactive column will be selected.
  • Inactive Only - Students with an I in the Active/Inactive column will be selected.

Defaults to Both

New/Existing Students

  • New Students Only - Students with student id numbers that currently do not exist in BusBoss™ will be selected.
  • Existing Students Only - Students with student id numbers that currently exist in BusBoss™ will be selected.

Defaults to Both

Grade

All of the grades currently found in the Import file will be listed. Only students with the assigned grades will be selected.

Defaults to All

School

All of the schools currently found in the Import file will be listed. Only students with the assigned schools will be selected.

Defaults to All

IMPORT STUDENTS UTILITY MENU

Import Students Utility Menu

This menu contains several utilities that allow you to easily change student data provided in the import file:

Pad Student ID With Zeros

If the student ID numbers in BusBoss™ have leading zeros, but the import file data does not, use this utility to add zeros to the beginning of each student ID.

Trim Student ID Removing Zeros

If the student ID numbers in BusBoss™ do not have leading zeros, but the import file data does, use this utility to remove zeros from the beginning of each student ID.

NOTE: Student ID numbers in the import file must exactly match the student ID numbers in BusBoss™ (including the same number of leading zeros) in order to update student data accurately.

Pad Grade With Zeros

Single digit grades must have a leading zero for accurate reporting. If the import file data does not have a leading zero, use this utility to add a zero to the beginning of each single digit grade in the import file.

Format Birth Dates

Six digit birth dates will be separated into date formats by forward slashes (i.e.. 063098 will be 06/30/98)

Eight digit birth dates will be separated into date formats by forward slashes (i.e.. 06301998 will be 06/30/1998)

Format Phone Numbers

Ten digit numbers will be separated into three parts by dashes (i.e. 1234567890 will be 123-456-7890)

Add Missing Race Types

Race Types are stored in the Lookup Tables - Race Type Tab. When invalid Race types are found, users can add new race types or replace them with valid race types. Click Utility and click Add Missing Race Types. The following screen will pop up.

Add Missing Race Types Screen

Only the Invalid race types will be listed in the Code column. Select the Action desired.

Add will add the Race Type with the description entered in the Change To column.

Replace With will change all of the students with the specific Code to use the Race Type entered in the Change To column.

NOTE: All of the invalid codes must have an Action and Change To entered. Codes are limited to 2 (two) alphanumeric characters.

Click OK to process the actions or Cancel to exit the screen.

If there aren't any Invalid Race Types, then the following screen will pop up.

Add Missing Race Type Error Screen

Add Missing School Codes

School Codes are made up of the School Code~District Code~County Code combination. School Codes are stored in the Maintain School - General Tab. When invalid school codes are found, users can add new school codes or replace them with valid school codes. Click Utility and click Add Missing School Codes. The following screen will pop up.

Add Missing School Codes Screen

Only the Invalid school codes will be listed in the Code column. Select the Action desired.

Add will add the School Code with the description entered in the Change To column. District Code and County Code will be set to blank when adding a new school code.

Replace With will change all of the students with the specific Code to use the School Code entered in the Change To column.

NOTE: All of the invalid codes must have an Action and Change To entered. Codes are limited to 20 (twenty) alphanumeric characters.

Click OK to process the actions or Cancel to exit the screen.

If there aren't any Invalid School Codes, then the following screen will pop up.

Add Missing School Codes Error Screen


Menu


How do I add an address?

Maintain->address. Add address.

How do I manually locate an address/all addresses?

Maintain-> address. Select either 'locate manually' to manually pinpoint one address or 'exact locate all' to have BusBoss automatically locate all unlocted addresses.

How do I add/move/delete an address?

All three of these things can be done in the Addresses dropdown menu along the top map toolbar. Select any of these options, then select the address you would like to move or delete, or select the point on the map where you would like to add an address.

How do I display addresses on the map?

Along the top map toolbar, there are three choices in the address dropdown menu for showing addresses. Selecting "Display Addresses" will allow you to choose which addresses specifically you would like to view on the map (by grade, school, race, etc. ). You can also select "Display all Addresses" or "Display Near Addresses", which will display either all addresses on the entire map, or just the section of the map that you have visible at the time, respectively.

How do I add an aide?

Maintain->aide->add. Enter all necessary information

How do I attach an aide to a route/bus/student?

In 'edit student->individual' tab, select the box stating "requires aide". In 'Maintain->route', select your route, then in the 'details' tab, click the aide icon to select the aide that will be attached to that route/bus.

How do I add a bus?

Maintain->bus->add. Enter all necessary information

How do I add a contractor?

Maintain->contractor->add. Enter all necessary information

If buses are s.d. owned, do I need to add a contractor for this?

Yes. You must add a contractor under the school district's name. Then when maintaining your buses, you must also select your school district as the contractor in the Maintain->bus->edit->contractor tab. Below the contractor name, ownership must be listed as "district owned" from the dropdown menu.

Can I move/delete/add a depot?

Yes. Using the depots dropdown menu, select which tool you would like to use. To move or delete a depot, just click on the depot you would like to move/delete, and to create one, select the point on the map where you would like a depot created.

How do I display depots on the map?

Along the top map toolbar, select the depot icon, then select "Display Depots" from the dropdown menu. This bring up a list of all depots. Select the depot you would like to see. Additionally, using the Symbols menu at the bottom of the map, you can view all depots at once.

How can I add to the Driver Employment Type list found in the Maintain Driver, Employment Tab?

From the file menu click on maintain, select Lookup Table, select Driver Type, and selct add

How do I add a driver?

Maintain->driver->add. Enter all necessary information

What happens when selecting the Tools, Driver, Delete unused menu option?

All drivers not assigned to routes are displayed in a list to manually select the drivers to delete.

I have too many things on my map, how do I clear them out?

You can use the eraser icon on the left map toolbar to remove certain icons from your map. (from view, not permanently). Click the eraser icon, and a screen will come up, bringing up a list of different things that are currently viewable on your map. you select which items you would like to remove and click "ok" and it will remove those items(routes, stops, schools) from your map.

Can I export my map?

You can export your map, using the "export to bitmap" icon on the left map toolbar. This will take your entire map and export it to a bitmap file, which you can then crop, enlarge, alter, and/or print however you would like.

Can I use stops/schools/depots that aren't located in my optimization?

No, Fleet Optimizer will only allow located stops, depots, and schools to be used during optimization. This will allow for BusBoss to provide the most efficient route based on the information given.

How do I make an optimized route permanent/active?

after optimizing your route, select it, and click 'activate' along the top menu bar.

How do I use fleet optimizer?

Maintain->fleet optimization->add. You then enter your purpose, max travel/ride time. Select your students and busses (must provide enough buses to meet the minimum req's of # of students/wheelchairs). Under 'routes' tab, select "optimize routes' this may take a moment. from there you can activate a route, view stops on the new route, or save for later editing/viewing.

How do I mark a road as hazardous/blocked?

In the top map toolbar, on the streets dropdown, there are selections to "toggle" roadblocks and hazard roads. Select the appropriate item, and click on the street that you would like to mark. BusBoss will then change the color of that section of the street to reflect your selection, and also keep this whenever you work in your database. If you choose to make a road blocked and there are already stops/routes on that section of road, a screen will come up reminding you of this, and giving you the option to optimize the selected routes immediately.

How do I set speed limits for a road?

If you would just like to set the limit for a single street, you can choose the information icon and select the street. In the following screen you can set the speed limit for that street, as well as the times that the speed limit applies to. If you want to set limits for all streets depending on type, select Tools->map->set speed limits. From there you can choose a baseline speedlimit for all roads, separated by street type (rd, st, cir, pkwy, etc.)

How do I set/change address ranges for a street?

Select the "information" icon on the left map toolbar. Click the section of street that you are interested in changing. The last tab on the following screen, "Address Ranges", will allow you to change the house numbers on that section.

What does the 'I' icon do?

The "I" icon on the left map toolbar is the "information" icon. If you click this button and then select any stop, street, intersection, depot, school, etc., you can then see (or get to) all the information about that selected area/item. It is a quick way to gain basic information on just about anything within the map part of BusBoss.

What if a road has multiple names?

On the left map toolbar, click the information icon, and select the road that you would like to add names for. In the information screen, you can add multiple names for the streets, then save.

What if they change during the day?

If a certain street changes speed limits during parts of the day, clicking the Information icon on the left map toolbar and selecting the street will bring up the screen where this can be changed. Go to the "Speed limit" tab, and you can set up a 24 hour timeline as to when and for how long the speed limit changes. Note: the beginning and end times for this screen must be 12:00am and 11:59pm, respectively. All times in between must match exactly (i.e. 12:00pm-2:00pm, 2:00pm-11:59pm)

How do I create a landmark?

From the landmarks dropdown menu, select "Add Landmark". Click on the point in the map where you would like the landmark to be. Then a screen will pop up, allowing you to choose from hundreds of icons which you can use for your landmark.

How do I display landmarks on my map?

Along the top map toolbar, select the landmarks icon, then select "Display All Landmarks" from the dropdown menu. This will show all the landmarks on your entire map.

How do I move/delete a landmark?

In either case, select the tool you would like to use from the landmarks dropdown menu, and then select the landmark you want to edit. This will either delete the landmark or select it so you can then move it to another point on the map.

What are layers on the map?

The layers on the map are the different pieces of information that make up the map as a whole. Streets, stops, streams, railroads, each of these is a layer. Certain layers (like streets and stops), can not be removed as a layer.

What do they layers do?

The layers icon is useful because if you are working on several routes with many stops on each route, you can select the layers icon, and bring the streets up to the top (for instance), and they can then be seen above all the other information that is still on your map. Another thing is that when you close your session in BusBoss, it will save the layout of your layers, so the next time you open BusBoss, the layers will appear exactly as they were when you closed it.

How can I add something to any of my dropdown menus?

Maintain->lookup table. Select the topic/area you would like to add a selection to, and click the 'add' button. Add your selection and click 'ok'

How do I print out my map?

Zoom in or out to the area of your map that you would like to print, and on the left map toolbar, select the printer icon. This will print only the viewable area of the map that you see on your screen, not the entire map.

Do I have to create a new scenario when graduating students?

You do not have to, however you should create a new scenario for your new school year to graduate into. Otherwise, when you graduate your students, all of last year's information will get overwritten and be lost.

How can I Modify the information field names used in the Student Information Tab?

From the file menu click on File, configuration, student tab, and edit the student information fields.

How do alerts work and how can I customize them?

Alerts are a set of reminders for the user regarding things within their database that may need to be fixed with some urgency. This can be customized by bringing up the alerts (Help->alerts), and clicking the "config" button at the top. From there a user can select the alerts he would like to see, as well as make different categories of users, with specific alerts designed for each category.

How do I add a street?

If there is a road that does not exist on your map, you are able to add it using the "add street" tool in the streets dropdown menu (along the top map toolbar). Just click this button and then draw in your street, noting the length of the street will show up in the top right hand corner of your map. After you finish drawing the street, the information screen will show up for your new street for you to fill in.

How do I set turn restrictions to streets?

On the map toolbar along the left, click the information button, then click on the intersection that you are interested in altering. The screen that comes up will allow you to add, edit, and delete turn restrictions for that intersection. If you click "Next" you can then set the restrictions for only certain types of vehicles or for only certain times during the day.

Where do students that ride the bus occasionally fit in?

Students that ride a bus occasionally should be put on a route and stop. If they are picked up every once in a while, then any reporting of mileage will be accurate for the state. Also, if a driver does not know when a student will ride, a note can be put on the stop to let the bus driver know this.

How can I pan through the map?

On the left map toolbar, under the "information" icon, is a blue cross with arrows, the "pan" icon. Click this icon and you can then move the map around instead of recentering to move it.

Can I change my right click function?

On the left map toolbar, there is a yellow cursor button. If you click this, it will toggle what happens

Can I delete a route?

Maintain->routes->delete. Select the route you would like to delete. If there are students/stops, or transfers assigned to this route, a warning will appear telling you so. Deleting the route will unassign any students and/or stops that were on the route, leaving the students unrouted. At this point you can choose to proceed or not in deleting the route.

How can I assign/unassign schools to a route?

Open/create the route you would like to work with. when creating a route initially busboss will ask for a school for the route to service. You may add more if necessary, or remove some as well. To do either of these, you will go to the details tab on the route. click on the school icon, and check/uncheck the schools you would like to add/remove for this route. if you try to remove a school that has students on that route attending it, or is currently being used as a transfer point, a notice will pop up reminding you of this. from there you have the choice to continue or not.

How can I calculate the mileage/time for one segment of a road/route?

Using the Point to Point function in the routes dropdown menu, you can calculate the time and mileage it would take from one point to another, or to run a series of points. Just select this tool from the dropdown menu, and click the points on the map you would like to calculate to and from. There can be as few as two points for this tool to work.

How can I change the path a route takes?

You will first select 'path->select path' and click on the area of the path that you would like change/reroute. You then select 'path->add path point' and click on the section of the path you previously hilighted, and drag it in the direction that you would like it to take. BusBoss should then begin showing you available alternative routes and you release the mouse when you have found the one you want.

How can I duplicate my route for am/pm runs?

Open/create the route you would like to make a copy of. At the top of the route screen select 'route->copy route'. Rename the 'copy' version of the route on the right, as well as making any changes to the start times, bus #'s, purpose, etc. you can also select at the bottom of this screen whether or not you would like the stops to remain in the same order or be in reverse (for am/pm runs). This can be used to experiment with a currently used route for efficiency, or to quickly generate an am/pm run for a currently used route.

How can I view info. On students assigned to a route?

Students can be viewed for either an individual stop or for an entire route. At the top of the route screen, click on the student icon, and any of the three selections can be made, to list students by stop, show students by stop, or show students by route. From this point, clicking the information icon to the left of the map, then clicking on a student's house will bring up their personal information, or by choosing them from the list will do the same thing.

How do I account for stops that I know will take longer to load/unload?

In BusBoss the user can set a standard load time for each stop. If, however, additional time needs to be added or subtracted from a stop, this can be done on the route. Click on the stop that you need to adjust, and at the bottom of the stop list is "Time Adjustment (minutes)". enter the number of minutes you would like to adjust the stop by.

How do I add a route?

Maintain->route->add. Enter all necessary information. When the purpose, start time, bus, driver, and school have been chosen, you may then select stops, additional schools, aides, and service days to the route.

How do I find all the routes that use a certain street?

Using the "Routes for Street" tool in the routes dropdown menu, you can see all the routes that travel along any selected section of street on your map. Just select this tool, and click on the street you are interested in viewing. This will hilight the section of that street, and bring up a screen listing all the routes that use that portion. This list can then be printed for reporting or reference purposes.

How do I make a route from stops?

Either open or add the route you would like to add the stops to. Click the stop sign at the top of the route page and select 'add stops to route'. Begin clicking on stops that you would like to add to your route. You can then move the stops in whatever order you would like using the same stop sign drop down, or by clicking and dragging a stop to the position you would like it to be in.

How do I optimize a route I've already made?

Open or create the route you would like to work with. at the top of the route screen, click on "routes->optimize stop order" busboss will then automatically optimize the stops you have listed for this route, putting them in the most efficient order. Remember, any stops that you have locked will not change at all, so to optimize completely a route, all stops must be unlocked.

How do I set the optimal time for a bus to start on a route?

Open the route you would like to edit. On the "details" screen, there is a section "start time". Clicking the bell icon to the right of the time will automatically set it so the bus arrives at the school you have associated with the route at the preferred bell time.

I want to see all my routes on the map, how?

On the routes dropdown menu along the top map toolbar, select "Display Routes". The screen that comes up will allow you to select the school(s) and specific (or all) route you would like to see on the map. Click "Select all Routes" to view all routes on the map.

The Tools, Route, Export to Tenex menu option can only be used if the district is using the Tenex Student Accounting System.

False, the student routing information is exported to a file, so it can be manually imported into any student accounting system

What happens when selecting the Tools, Route, Export to Tenex menu option?

All student routing information is exported to a file

What is the different between add/insert a stop?

Adding a stop will add it to the end of a route, and inserting a stop will insert the stop within the route at the stop you have hilighted.

When I optimize my route, my edited path disappears, why?

You need to lock your stop. This will take any changes you have made to the stop and lock them so they can not be changed during any automatic configuration/optimization. To do this, select the stop you would like to lock, click on the stop sign at the top of the route screen, and select 'lock/unlock stop'. This will lock (or unlock) your stop. During optimization, any changes you made to the path will remain. You can also use Path Points to avoid this.

Can I delete a school?

A school cannot be deleted if historical information exists for it. However if a school is no longer in use, it is better to make the school inactive, to keep historical information accurate within your database.

How can I change the walk to school/stop distance for a school?

Maintain->school->general. In this tab you can edit the distance a student can walk to a bus stop, as well as the distance a student can walk to that school.

How do I add a school?

Maintain->school->add. Enter all necessary information

How do I set a school as a transfer point?

Maintain->school->edit. Choose the school you would like to edit. On the General tab, select the box that says 'use school as transfer'. You can get to this screen as well by clicking the 'I' (information) icon on the left of the map, then clicking on the school within the map.

How do I set up the school's calendar?

Maintain->school->edit. Choose the school you would like to edit. Along the top of the edit school screen, click the icon that says "cal". From here you can maintain the calendar for the school. You can also set a day type for multiple schools at once using the tools->set calendar day type function. From there you can select the type of day (no school, half day, etc.) as well as the schools affected, and it will change all of them at once.

Can I copy a school calendar?

Yes. From the menu bar click maintain, select school, click edit, click the cal button. To copy the school calendar to another school click copy calendar to, select the school(s) that will receive a copy of the calendar data and click ok.

Can I move a school?

Yes. Select "Move School" from the schools dropdown menu, then click on the school you would like to move. Click again on the point where you would like to move the school to, and the process is complete.

How do I display schools on the map?

In the Schools dropdown menu, choose "Display Schools". You can then sort through a list of criteria to choose which schools you would like to display. When selecting "Display All Schools", it will display all schools over the entire map.

How do I set up a sex offender?

Maintain->sex offender->add. Enter all necessary information

What do the different threat levels mean?

Customarily the different threat levels correspond with the radius from the threat that is shaded. A more serious threat will have a larger radius shaded, however the different threat levels can be understood to mean different things (type of threat, etc. ) for different school districts.

How do I display sex offenders on the map?

Along the top map toolbar, select the sex offenders icon, then select "Display All Sex Offenders" from the dropdown menu. This will show all the offenders on your entire map.

How do I see if there are any stops within threat zones?

On the sex offenders dropdown menu, select "Display Sex Offender Problems". This will bring up all of the offender zones in which there are stops.

Can I delete a stop?

yes, this can be done two ways. The first way is to use the stop sign icon along the top of the map, and select 'delete stop', then click on the stop you would like to delete. The second way is to select the stop in the maintain->stops screen, then click the delete stop icon at the top of that screen. In either case, the stop will not be deleted if it is currently used for routing, if there are students assigned to it, if it is used as a transfer point, or if it is used in any historical data.

How do I add a stop?

On the map toolbar, click the stop sign, then add stop. Select point on map where stop is located. Enter further necessary information.

How do I change the school(s) a stop services?

Select the stop you would like to add a school to. Edit the stop by clicking on the stop sign icon with the "e" over it. Click "select schools", and check the school you would like to add to this stop.

How do I combine multiple stops into one?

Use Tools ->Stops -> Combine Current Stops. On the next screen, select the stops to combine, and the stop location that the combined stops will be at.

How do I create house stops for my students?

Tools->stops->create house stops. Select the school you would like to do this for, and the tool will run, creating a house stop for every located student address assigned to the selected school.

How do I find stops close to a student for routing?

Locate the student's address on the map. Then in the 'stop' tab in the 'assign days' screen of 'edit student', you can select one of two icons. The first, 'show closest stop for school', will show you all stops within the walk to stop distance that service the same school as the student attends. the second icon 'show all closest stops', shows all stops within the walk to stop distance that service any school.

How do I locate an unlocated stop?

In Maintain-> stops, select the stop sign with a 'u' over it, that will list all your unlocated stops. Select the stop you would like to locate. From here you can choose to either manually locate the stop using the stop sign with the pushpin icon, or auto locate the stop by selecting the stop sign icon. THis can also be done from the Maintain->students screen, assign days tab, under 'stops'. Select the icon to manually locate the stop and you can click on the map where the stop should be.

How do I move a stop?

Along the map toolbar, click on the stop sign, then 'move stop'. Select the stop you would like to move, then click in the new location you would like the stop to be.

How do I see what route a stop is on?

Select the stop you would like to view routes on, then select the edit stop icon. Click the 'routes' icon, and this will show you what routes, days, and times this stop is serviced.

How do I set a stop as a transfer point?

In the stop screen, select the stop you would like to set, and edit the stop using the stop sign icon with the "E" over it. You can then check the box that says "Stop can be used as transfer". You can also get to this screen by clicking the "I" (information) icon on the left side of the map, then clicking on the stop you would like to edit.

How do I set a stop as private?

Same directions as setting a stop as a transfer point.

How do I split a stop into two separate ones?

Tools->Stops->split current stops. On the next screen you select the stop you would like to split, then you name the new stop, and choose which students you would like to move over to the new stop. This will then place a second stop at the same location as the first, but split the students that are picked up/dropped off at each stop.

What does "reset school stops" do?

This tool will look at the routes and stops, and see what school the bus ends up at, then resets all stops on that route to service the school the bus ends up at.

How can I display all stops on the map?

Select the "display all stops" tool from the stops dropdown menu along the top map toolbar. This will display all known stops on your entire map.

How do I add/delete/move a stop?

Any of these functions can be completed by using the stops dropdown menu along the top map toolbar. Select what you would like to do to the stop, then select the stop.

How do I only display certain stops on the map?

By selecting the "Display Stops" tool from the stops dropdown menu, you can select from a list of criteria which stops you would like to be visible on your map. You can choose from purpose, grade, race, school, etc.

Can I add/delete a street?

A street can be added and/or deleted from the top menu toolbar, Street dropdown menu. In this menu, you can add a street by clicking at the beginning of the street and dragging the length of the street, or delete a street by selecting the street you would like to get rid of.

Can I set a street as "one way"?

On the top map toolbar, in the street dropdown menu, select "set one way street". Then you can select the street that you would like to make one way. This will only work for a section of the road, not the entire length. You must select each section that you want to change (for situations where only part of a street is one way)

How can I see all my dead ends?

Along the top map toolbar, in the streets dropdown menu, select "display dead ends". This will show all your dead end roads on the map.

How do I find a street/address on the map?

Select the street icon on the top map toolbar, and choose "Find Street" or "Find Street Address" from the dropdown menu. On the next screen you can enter the name of a street to find the entire road, or enter a street address to find a specific point along a street.

How do I find an intersection on the map?

Select the street icon on the top map toobar, and choose "Find Intersection". On the next screen you can enter your intersection information and it will locate any possible matches on the map.

What does it mean to split a street?

An entire length of a road is divided up into smaller sections, called breaking points. Usually these section points coincide with intersections, but a long straight section of road may have several "nodes"(breaking points) along it. When placing a stop on a street, BusBoss will look for the closest node to associate the stop with, usually being the same spot the stop is in. Occasionally, however, the route will pass the stop, or not get to it, because the naturally occurring closest node does not align with the stop. At this point it is necessary to split the street to manually create a node closest to your stop or school. By selecting "split street" from the street dropdown menu along the top map toolbar, and selecting the point on the street you would like to break, this will create the node you need along your road.

Can I delete a student?

Yes. However it is best to make a student inactive so that they will still be counted toward the yearly state reports.

How do I add a student to a stop/route?

Select the stop sign icon from the top of the map, and click "assign students to stop". From this screen you can then view unassigned students, select to manually assign a student to a stop, show closest stops, or have BusBoss automatically assign all students to stops.

How do I add a student?

Maintain->student->add. Enter all necessary information

How do I set up a child who has split custody arrangements?

Maintain->student->edit. Choose the student you would like to edit. On the left side of the screen, select "split custody" from the list. Check the box that says 'assign/unassign split custody'. From there you can assign an address, stop, school, and route for the child. you must add the second address in the 'address' screen to the left, so you can then assign it as the split custody address.

How do I set up a student to transfer for a half day program?(Second School)

In order to set up a child for a transfer, several things must happen. If the child is going to another school during the day, in the "second School" screen in maintain student, you need to check the box "student attends half day program". From there you must enter the second school, the route to the school, and route from the school (if the child goes back to their first school prior to going home). If the student goes straight home from the second school, just set up the pm route in the "assign days" tab to take them from the second school home, and do not enter anything in the "route from school" box in the "second school screen".

Where do I go to make a student inactive?

Maintain->student->edit. Choose the student you would like to edit. On the left side of the screen, select 'Individual' from the list, and at the bottom, select 'inactive'. This will then make the studen inactive in busboss.

How do I view all students on the map?

On the top map toolbar, select the student icon then select "display all students". From this point you can choose to show the students at their home location, pickup stop, or dropoff stop location.

Can I move/delete/add a transfer?

Yes. Using the transfers dropdown menu, select which tool you would like to use. To move or delete a transfer, just click on the transfer you would like to move/delete, and to create one, select the point on the map where you would like a transfer created.

How do I display transfers on the map?

Along the top map toolbar, select the depot icon, then select "Display Transfers" from the dropdown menu. This bring up a list of all transfers. Select the transfer you would like to see. Additionally, using the Symbols menu at the bottom of the map, you can view all transfers at once.

How can I change my password?

From the file menu click on file, change password

How do I add a user?

Maintain->User. Add user button.

How do I delete a user?

Maintain->user. Delete user button.

How I set permission levels for my users?

Maintain->user. Select the "security" icon. From there you can select what level of access you want certain groups/users to have throughout busboss.

What are the user permission settings available from within BusBoss?

No Access, Read Only and Full Access

How can I get a list of students living within a pre-defined area of the map?

From the file menu click on Reports, Zones, and Students within Zone

How do I display the entire zone on the map?

From the file menu click on Maintain, Zone, and then click on zoom to full from the left map menu

How do I set up a zone?

Maintain->zone->add. Enter all necessary information

How do I zoom in/out on the map

On the left map toolbar, you can use the magnifying glasses with the "+" or "-" signs on them to zoom in and out of the map. If you would like to zoom in on a particular area of the map, you can draw a box around that area by clicking on the map and dragging around the area, and it will zoom in. You can also click on a point in the map and use your mouse's scroll wheel to zoom in and out of the map. You can also use the "+" or "-" keys.

I'm confused about where I am on the map, can I zoom out all the way?

Yes. On the left map toolbar, there is an icon with a map with a box around it. Clicking this zoom your map out to full view. From this point you can see the entire map in one screen. This is useful to see how large a zone would be, or where a large concentration of your stops/routes may fall in comparison to other landmarks.